Minimum system requirements

The do-it.org website is support by the following browsers:

- Chrome

- Safari - Version 7 or later

- Internet Explorer - Versions 8 or later

- FireFox - Version 31 or later

- Edge

To check what browser you are using please go to this website.

 

We also recommend that you have JavaScript enabled.

To check if you have JavaScript enabled and if not how to enable it please go here.

Have more questions? Submit a request

0 Comments

Article is closed for comments.
Powered by Zendesk