Minimum site requirements

The Do IT website is support by the following browsers:

- Chrome - version 66 or higher

- Safari - version 10.1 or higher

- Internet Explorer - version 11 or higher

- FireFox - version 60 or higher

- Edge - version 41 or higher

0 Comments

Article is closed for comments.
Powered by Zendesk